adobe/css-tools · Security

@adobe/css-tools Improper Input Validation and Inefficient Regular Expression Complexity

GHSA ID
GHSA-prr3-c3m5-p7q2
CVE ID
CVE-2023-48631
Severity
medium
Published
Updated
CVSS
5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
CVSS v3
5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L

Description

Impact

@adobe/css-tools version 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

Patches

The issue has been resolved in 4.3.2.

Workarounds

None

References

N/A

CWEs

References