ansibleguy/webui · Security

ansibleguy-webui Cross-site Scripting vulnerability

GHSA ID
GHSA-927p-xrc2-x2gj
CVE ID
CVE-2024-36110
Severity
high
Published
Updated
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L
CVSS v3
8.2 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L

Description

Impact

Multiple forms in version <0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser.

Patches

We recommend to upgrade to version >= 0.0.21

References

CWEs

References