apache/airflow · Security

Apache Airflow: DAG Code and Import Error Permissions Ignored

GHSA ID
GHSA-6v6w-h8m6-7mv2
CVE ID
CVE-2024-27906
Severity
medium
Published
Updated
CVSS v4
5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI.

Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

CWEs

References