apache/airflow · Security

Apache Airflow: Ignored Airflow Permission

GHSA ID
GHSA-h574-6646-vfxx
CVE ID
CVE-2024-28746
Severity
medium
Published
Updated

Description

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. 

Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

CWEs

References