apache/airflow · Security
Apache Airflow MySQL Provider is Vulnerable to SQL Injection
- GHSA ID
- GHSA-hhm6-jjf4-6pm3
- CVE ID
- CVE-2025-27018
- Severity
- medium
- Published
- Updated
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS v3
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS v4
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
CWEs
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-27018 ↗
- https://github.com/apache/airflow/pull/47254 ↗
- https://github.com/apache/airflow/pull/47255 ↗
- https://lists.apache.org/thread/m8ohgkwz4mq9njohf66sjwqjdy28gvzf ↗
- http://www.openwall.com/lists/oss-security/2025/03/19/4 ↗
- https://github.com/advisories/GHSA-hhm6-jjf4-6pm3 ↗