apache/atlas · Security
Apache Atlas has a Code Injection Vulnerability
- GHSA ID
- GHSA-35xx-9xrg-gwhf
- CVE ID
- CVE-2026-40563
- Severity
- high
- Published
- Updated
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- CVSS v3
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Description
Description:
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas.
Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data.
Affected Version:
This issue affects Apache Atlas: from 0.8-incubating through 2.4.0.
For affected versions >= 2.0.0, the vulnerability is only exploitable when Atlas is deployed with below non-default configuration.
atlas.dsl.executor.traversal=false
Mitigation:
Users are recommended to upgrade to version 2.5.0, which fixes the issue.
CWEs
- CWE-94 · Improper Control of Generation of Code ('Code Injection')