apache/camel · Security
Apache Camel-Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
- GHSA ID
- GHSA-46jf-c9vx-hh79
- CVE ID
- CVE-2026-46587
- Severity
- high
- Published
- Updated
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CVSS v3
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
CWEs
- CWE-20 · Improper Input Validation
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-46587 ↗
- https://camel.apache.org/security/CVE-2026-46587.html ↗
- http://www.openwall.com/lists/oss-security/2026/07/06/15 ↗
- https://github.com/apache/camel/pull/23228 ↗
- https://github.com/apache/camel/pull/23230 ↗
- https://github.com/apache/camel/pull/23231 ↗
- https://github.com/apache/camel/commit/8d74cdca9befc74b49d9c52ac6a145be1d413e7d ↗
- https://github.com/apache/camel/commit/c16f7ef39849ae8819f50c959b538350b8f839e9 ↗
- https://github.com/apache/camel/commit/d0dfa4e0ebd062acaf4a86ca476bb4305db9bfd4 ↗
- https://github.com/apache/camel/releases/tag/camel-4.14.8 ↗
- https://github.com/apache/camel/releases/tag/camel-4.18.3 ↗
- https://github.com/apache/camel/releases/tag/camel-4.21.0 ↗
- https://github.com/advisories/GHSA-46jf-c9vx-hh79 ↗