apache/commons-compress · Security
Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
- GHSA ID
- GHSA-4g9r-vxhx-9pgx
- CVE ID
- CVE-2024-25710
- Severity
- medium
- Published
- Updated
- CVSS
- 5.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
- CVSS v3
- 5.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress. This issue affects Apache Commons Compress: from 1.3 through 1.25.0.
Users are recommended to upgrade to version 1.26.0 which fixes the issue.
CWEs
- CWE-835 · Loop with Unreachable Exit Condition ('Infinite Loop')
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-25710 ↗
- https://lists.apache.org/thread/cz8qkcwphy4cx8gltn932ln51cbtq6kf ↗
- http://www.openwall.com/lists/oss-security/2024/02/19/1 ↗
- https://security.netapp.com/advisory/ntap-20240307-0010 ↗
- http://seclists.org/fulldisclosure/2024/Aug/37 ↗
- https://github.com/advisories/GHSA-4g9r-vxhx-9pgx ↗