apache/cordova-plugin-inappbrowser · Security

Privilege Escalation in cordova-plugin-inappbrowser

GHSA ID
GHSA-c6pw-q7f2-97hv
CVE ID
CVE-2019-0219
Severity
critical
Published
Updated
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS v3
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Versions of cordova-plugin-inappbrowser prior to 3.1.0 are vulnerable to Privilege Escalation. A website running in the InAppBrowser webview on Android could execute arbitrary JavaScript in the main application's webview using a specially crafted gap-iab: URI. This affects Cordova Android applications using the package.

Recommendation

Upgrade to version 3.1.0 or later.

CWEs

References