apache/dolphinscheduler · Security
Apache DolphinScheduler vulnerable to Improper Input Validation
- GHSA ID
- GHSA-3xh5-8hvq-rc8x
- CVE ID
- CVE-2022-45875
- Severity
- critical
- Published
- Updated
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS v3
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS v4
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
Apache DolphinScheduler improperly validates script alert plugin parameters and is vulnerable to remote command execution. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. Users should upgrade to version 3.0.2 or 3.1.1.
CWEs
- CWE-20 · Improper Input Validation
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-45875 ↗
- https://lists.apache.org/thread/r0wqzkjsoq17j6ww381kmpx3jjp9hb6r ↗
- http://www.openwall.com/lists/oss-security/2023/11/22/2 ↗
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-dolphinscheduler/PYSEC-2023-4.yaml ↗
- https://github.com/advisories/GHSA-3xh5-8hvq-rc8x ↗