apache/flink-cdc · Security

Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers

GHSA ID
GHSA-wqm3-w3p6-xjgm
CVE ID
CVE-2025-62228
Severity
medium
Published
Updated
CVSS v4
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L

Description

Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.

CWEs

References