apache/geode · Security

Apache Geode web-api is vulnerable to Cross-site Scripting

GHSA ID
GHSA-w595-4975-gm3h
CVE ID
CVE-2024-44088
Severity
medium
Published
Updated
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS v3
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover.

This issue affects Apache Geode: all versions prior to 1.15.2.

Users are recommended to upgrade to version 1.15.2, which fixes the issue.

CWEs

References