apache/incubator-answer · Security

Apache Answer: Predictable Authorization Token Using UUIDv1

GHSA ID
GHSA-mr95-vfcf-fx9p
CVE ID
CVE-2024-45719
Severity
low
Published
Updated
CVSS
2.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
CVSS v3
2.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
CVSS v4
2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

Description

Inadequate Encryption Strength vulnerability in Apache Answer.

This issue affects Apache Answer: through 1.4.0.

The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.

CWEs

References