apache/jspwiki · Security

Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin

GHSA ID
GHSA-72ww-4rcw-mc62
CVE ID
CVE-2025-24854
Severity
medium
Published
Updated
CVSS v4
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.

Apache JSPWiki users should upgrade to 2.12.3 or later.

CWEs

References