apache/jspwiki · Security

Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability via Header Link Rendering

GHSA ID
GHSA-rrff-chj9-w4c7
CVE ID
CVE-2025-24853
Severity
medium
Published
Updated
CVSS v4
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

A carefully crafted request when creating a header link using the wiki markup syntax, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.

Further research by the JSPWiki team showed that the markdown parser allowed this kind of attack too.

Apache JSPWiki users should upgrade to 2.12.3 or later.

CWEs

References