apache/karaf · Security

Apache Karaf vulnerable to relative path traversal

GHSA ID
GHSA-fjw4-39pg-vf4f
CVE ID
CVE-2019-0226
Severity
medium
Published
Updated
CVSS
4.9 · CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
CVSS v3
4.9 · CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

Description

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

CWEs

References