apache/kylin · Security

Apache Kylin Code Injection via JDBC Configuration Alteration

GHSA ID
GHSA-29m8-wh9p-5wc4
CVE ID
CVE-2025-30067
Severity
low
Published
Updated
CVSS v4
2.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.1.

Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

CWEs

References