apache/kyuubi · Security

Apache Kyuubi Server vulnerable to Path Traversal

GHSA ID
GHSA-f8r6-6222-9pvc
CVE ID
CVE-2025-66518
Severity
high
Published
Updated
CVSS v4
8.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L

Description

Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config.

This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2.

Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.

CWEs

References