apache/superset · Security
Apache Superset: Error verbosity exposes metadata in analytics databases
- GHSA ID
- GHSA-2cx9-54hp-r698
- CVE ID
- CVE-2024-53948
- Severity
- medium
- Published
- Updated
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS v3
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS v4
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N
Description
Generation of Error Message Containing analytics metadata Information in Apache Superset.
This issue affects Apache Superset: before 4.1.0.
Users are recommended to upgrade to version 4.1.0, which fixes the issue.
CWEs
- CWE-209 · Generation of Error Message Containing Sensitive Information
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-53948 ↗
- https://lists.apache.org/thread/8howpf3png0wrgpls46ggk441oczlfvf ↗
- https://github.com/apache/superset/commit/ac3a10d8f192520580b8ce545cf418dc7928d27c ↗
- http://www.openwall.com/lists/oss-security/2024/12/09/3 ↗
- https://github.com/advisories/GHSA-2cx9-54hp-r698 ↗