apache/superset · Security

Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

GHSA ID
GHSA-5474-f7g5-273q
CVE ID
CVE-2024-24773
Severity
medium
Published
Updated
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
CVSS v3
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1, which fixes the issue.

CWEs

References