apache/superset · Security
Apache Superset's chart visualization has a stored Cross-Site Scripting (XSS) vulnerability
- GHSA ID
- GHSA-fj97-2v9x-w5m4
- CVE ID
- CVE-2025-55672
- Severity
- medium
- Published
- Updated
- CVSS v4
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user.
This issue affects Apache Superset: before 5.0.0.
Users are recommended to upgrade to version 5.0.0, which fixes the issue.
CWEs
- CWE-80 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)