apache/superset · Security

Apache Superset allows privileged users to conduct error-based SQL Injection

GHSA ID
GHSA-gvxg-9hqx-f4rg
CVE ID
CVE-2026-23980
Severity
medium
Published
Updated
CVSS v4
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters.

This issue affects Apache Superset: before 6.0.0.

Users are recommended to upgrade to version 6.0.0, which fixes the issue.

CWEs

References