apache/superset · Security
Apache Superset SQL injection vulnerability
- GHSA ID
- GHSA-jfxj-xf67-x723
- CVE ID
- CVE-2023-49736
- Severity
- medium
- Published
- Updated
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS v3
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Description
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
CWEs
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-49736 ↗
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1p ↗
- https://github.com/apache/superset/pull/25779 ↗
- https://github.com/apache/superset/commit/1d403dab9822a8cee6108669c53e53fad881c751 ↗
- https://github.com/apache/superset/commit/34101594e284ab3acce692f41aff7759ccb4bf1d ↗
- http://www.openwall.com/lists/oss-security/2023/12/19/2 ↗
- https://github.com/advisories/GHSA-jfxj-xf67-x723 ↗