apache/superset · Security
Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections
- GHSA ID
- GHSA-mwf2-qr4v-94h2
- CVE ID
- CVE-2026-23984
- Severity
- high
- Published
- Updated
- CVSS v4
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Description
An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements.
This issue affects Apache Superset: before 6.0.0.
Users are recommended to upgrade to version 6.0.0, which fixes the issue.
CWEs
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CWE-863 · Incorrect Authorization