apache/thrift · Security

Apache Thrift has an Improper Validation of Certificate with Host Mismatch Vulnerability

GHSA ID
GHSA-7pwc-h2j2-rjgj
CVE ID
CVE-2026-43869
Severity
high
Published
Updated
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS v3
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

CWEs

References