apache/thrift · Security
Apache Thrift Python bindings have a Improper Validation of Certificate with Host Mismatch vulnerabilit
- GHSA ID
- GHSA-hwrj-9rr4-24xh
- CVE ID
- CVE-2026-66053
- Severity
- medium
- Published
- Updated
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS v3
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings.
This issue affects Apache Thrift: before 0.24.0.
Users are recommended to upgrade to version 0.24.0, which fixes the issue.
This replaces CVE-2026-41603
CWEs
- CWE-297 · Improper Validation of Certificate with Host Mismatch