apache/thrift · Security

Apache Thrift Node.js bindings vulnerable to Uncontrolled Recursion

GHSA ID
GHSA-r67j-r569-jrwp
CVE ID
CVE-2026-41636
Severity
high
Published
Updated
CVSS v4
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L

Description

Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

CWEs

References