auth0/auth0-php · Security

Auth0 PHP SDK has Insufficient Entropy in Cookie Encryption

GHSA ID
GHSA-w3wc-44p4-m4j7
CVE ID
CVE-2026-34236
Severity
high
Published
Updated
CVSS
8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
CVSS v3
8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N

Description

Impact

In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.

Am I Affected?

Consumers are affected if their application meets the following preconditions:

  • Their application is using the Auth0-PHP SDK, versions between 8.0.0 and 8.18.0
  • Their application is using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK:
    • Auth0/symfony,
    • Auth0/laravel0-auth0, or
    • Auth0/wordpress

Resolution

Upgrade Auth0/Auth0-PHP to version 8.19.0 or greater.

CWEs

References