auth0/laravel-auth0 · Security
Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency
- GHSA ID
- GHSA-7hh9-gp72-wh7h
- Severity
- medium
- Published
- Updated
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS v3
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Description
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Users are affected if they meet the following preconditions:
- Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0,
- Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.
Resolution
Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
CWEs
- CWE-863 · Incorrect Authorization
- CWE-1395 · Dependency on Vulnerable Third-Party Component