auth0/laravel-auth0 · Security

Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

GHSA ID
GHSA-fmg6-246m-9g2v
Severity
high
Published
Updated
CVSS
8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
CVSS v3
8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N

Description

Impact

In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.

Am I Affected?

You are affected if you meet the following preconditions:

  • Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0
  • Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.

Resolution

Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.

CWEs

References