auth0/nextjs-auth0 · Security

Auth0 Next.js SDK has Improper Proxy Cache Lookup

GHSA ID
GHSA-xq8m-7c5p-c2r6
CVE ID
CVE-2026-40155
Severity
medium
Published
Updated
CVSS
5.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
CVSS v3
5.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N

Description

Description

In affected versions of the Next.js SDK, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results.

Which Projects are Affected?

Users are affected if they meet all of the following preconditions:

  • Applications using the auth0/nextjs-auth0 SDK, versions 4.12.0 to 4.17.0, and
  • Applications using the proxy handler /me/* and /my-org/* with DPoP enabled.

Affected product and versions

Auth0/nextjs-auth0 v4.12.0 to 4.17.0

Resolution

Upgrade Auth0/nextjs-auth0 version to v4.18.0 or greater

Acknowledgements

Okta would like to thank Reynaldo Immanuel for their discovery and responsible disclosure.

CWEs

References