auth0/passport-wsfed-saml2 · Security

Passport-wsfed-saml2 allows SAML Authentication Bypass via Signature Wrapping

GHSA ID
GHSA-wjmp-wphq-jvqf
CVE ID
CVE-2025-46572
Severity
critical
Published
Updated
CVSS v4
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Description

Overview

This vulnerability allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP.

Am I Affected?

You are affected by this SAML Signature Wrapping vulnerability if you are using passport-wsfed-saml2 version 4.6.3 or below, specifically under the following conditions:

  1. The service provider is using passport-wsfed-saml2,
  2. A valid SAML document signed by the Identity Provider can be obtained.

Fix

Upgrade to v4.6.4 or greater.

CWEs

References