auth0/wordpress · Security

Auth0 Wordpress plugin Does Not Properly Handle File Types in Bulk User Import

GHSA ID
GHSA-w22c-pw5m-482x
Severity
low
Published
Updated
CVSS
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
CVSS v3
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N

Description

Overview

In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.

Am I affected?

You are affected by this vulnerability if you meet the following preconditions:

  1. Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.3.0,
  2. Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0.

Fix

Upgrade Auth0 Wordpress plugin to version 5.4.0 or greater.

Acknowledgement

Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.

CWEs

References