caronc/apprise · Security

Apprise vulnerable to regex injection with IFTTT Plugin

GHSA ID
GHSA-qhmp-h54x-38qr
CVE ID
CVE-2021-39229
Severity
high
Published
Updated
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS v3
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS v4
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

Impact

Anyone publicly hosting the Apprise library and granting them access to the IFTTT notification service.

Patches

Update to Apprise v0.9.5.1

# Install Apprise v0.9.5.1 from PyPI
pip install apprise==0.9.5.1

The patch to the problem was performed here.

Workarounds

Alternatively, if upgrading is not an option, you can safely remove the following file:

  • apprise/plugins/NotifyIFTTT.py

The above will eliminate the ability to use IFTTT, but everything else will work smoothly.

For more information

If you have any questions or comments about this advisory:

Additional Credit

Github would not allow me to additionally credit Rasmus Petersen, but I would like to put that here at the very least - thank you for finding and reporting this issue along with those already credited

Additional Notes:

  • Github would not allow me to add/tag the 2 CWE's this issue is applicable to (only CWE-400). The other is: CWE-730 (placed in the title)

CWEs

References