ckeditor/ckeditor4 · Security

Widget feature vulnerability allowing to execute JavaScript code using undo functionality

GHSA ID
GHSA-6226-h7ff-ch6c
CVE ID
CVE-2021-32808
Severity
high
Published
Updated
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
CVSS v3
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N

Description

Affected packages

The vulnerability has been discovered in Widget plugin if used alongside Undo feature.

Impact

A potential vulnerability has been discovered in CKEditor 4 Widget package. The vulnerability allowed to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0.

Patches

The problem has been recognized and patched. The fix will be available in version 4.16.2.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.

CWEs

References