ckeditor/ckeditor4 · Security
Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality
- GHSA ID
- GHSA-7889-rm5j-hpgg
- CVE ID
- CVE-2021-32809
- Severity
- medium
- Published
- Updated
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- CVSS v3
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
Description
Affected packages
The vulnerability has been discovered in clipboard plugin. All plugins with clipboard plugin dependency are affected:
Impact
A potential vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2.
Patches
The problem has been recognized and patched. The fix will be available in version 4.16.2.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Acknowledgements
The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.
CWEs
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
References
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7889-rm5j-hpgg ↗
- https://nvd.nist.gov/vuln/detail/CVE-2021-32809 ↗
- https://lists.fedoraproject.org/archives/list/[email protected]/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/ ↗
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/ ↗
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/ ↗
- https://www.oracle.com/security-alerts/cpuoct2021.html ↗
- https://www.oracle.com/security-alerts/cpujan2022.html ↗
- https://github.com/advisories/GHSA-7889-rm5j-hpgg ↗