ckeditor/ckeditor5 · Security
CKEditor 5 Markdown plugin Regular expression Denial of Service
- GHSA ID
- GHSA-hgmg-hhc8-g5wr
- CVE ID
- CVE-2021-21254
- Severity
- medium
- Published
- Updated
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS v3
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Description
Impact
A regular expression denial of service (ReDoS) vulnerability has been discovered in the CKEditor 5 Markdown plugin code. The vulnerability allowed to abuse a link recognition regular expression, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 Markdown plugin at version <= 24.0.0.
Patches
The problem has been recognized and patched. The fix will be available in version 25.0.0.
Workarounds
The user can work around the issue by:
- Upgrading CKEditor 5 to version 25.0.0.
- Disabling the Markdown plugin.
More information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Acknowledgements
The CKEditor 5 team would like to thank Erik Krogh Kristensen from the GitHub team for recognizing this vulnerability and Alvaro Muñoz from GitHub for reporting it.
CWEs
- CWE-400 · Uncontrolled Resource Consumption
References
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-hgmg-hhc8-g5wr ↗
- https://github.com/ckeditor/ckeditor5/releases/tag/v25.0.0 ↗
- https://www.npmjs.com/package/@ckeditor/ckeditor5-markdown-gfm ↗
- https://nvd.nist.gov/vuln/detail/CVE-2021-21254 ↗
- https://github.com/advisories/GHSA-hgmg-hhc8-g5wr ↗