ckeditor/ckeditor5 · Security
CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package
- GHSA ID
- GHSA-x9gp-vjh6-3wv6
- CVE ID
- CVE-2025-58064
- Severity
- low
- Published
- Updated
- CVSS v4
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
Description
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration.
This vulnerability affects only installations where the editor configuration meets one of the following criteria:
- HTML embed plugin is enabled
- Custom plugin introducing editable element which implements view
RawElementis enabled
Patches
The problem has been recognized and patched. The fix will be available in version 46.0.3 (and above), and explicitly in version 45.2.2.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
CWEs
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')