cloudflare/workers-sdk · Security
Cloudflare Wrangler directory traversal vulnerability
- GHSA ID
- GHSA-8c93-4hch-xgxp
- CVE ID
- CVE-2023-3348
- Severity
- medium
- Published
- Updated
- CVSS
- 5.7 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CVSS v3
- 5.7 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Description
Impact
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Patches
Wrangler2: Upgrade to v2.20.1 or higher. Wrangler3: Upgrade to v3.1.1 or higher.
References
CWEs
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
References
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-8c93-4hch-xgxp ↗
- https://github.com/cloudflare/workers-sdk/pull/3498 ↗
- https://github.com/cloudflare/workers-sdk/commit/fddffdf0c23d2ca56f2139a2c6bc278052594cba ↗
- https://github.com/cloudflare/workers-sdk/releases/tag/wrangler%403.1.1 ↗
- https://nvd.nist.gov/vuln/detail/CVE-2023-3348 ↗
- https://developers.cloudflare.com/workers/wrangler/ ↗
- https://github.com/cloudflare/workers-sdk ↗
- https://github.com/advisories/GHSA-8c93-4hch-xgxp ↗