codeigniter4/framework · Security
Cross-site Scripting Vulnerability in CodeIgniter4
- GHSA ID
- GHSA-7528-7jg5-6g62
- CVE ID
- CVE-2022-21715
- Severity
- medium
- Published
- Updated
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CVSS v3
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Description
Impact
Cross-Site Scripting (XSS) vulnerability was found in API\ResponseTrait in Codeigniter4.
Attackers can do XSS attacks if you are using API\ResponseTrait.
Patches
Upgrade to v4.1.8 or later.
Workarounds
Do one of the following:
- Do not use
API\ResponseTraitnorResourceController - Disable Auto Route and Use Defined Routes Only
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in codeigniter4/CodeIgniter4
- Email us at SECURITY.md
CWEs
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
References
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-7528-7jg5-6g62 ↗
- https://nvd.nist.gov/vuln/detail/CVE-2022-21715 ↗
- https://github.com/codeigniter4/CodeIgniter4/commit/70d881cf5322b7c32e69516aebd2273ac6a1e8dd ↗
- https://codeigniter4.github.io/userguide/incoming/routing.html#use-defined-routes-only ↗
- https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-21715.yaml ↗
- https://github.com/advisories/GHSA-7528-7jg5-6g62 ↗