duke-git/lancet · Security
Lancet vulnerable to path traversal when unzipping files
- GHSA ID
- GHSA-pp3f-xrw5-q5j4
- CVE ID
- CVE-2022-41920
- Severity
- high
- Published
- Updated
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS v3
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
Impact
What kind of vulnerability is it? Who is impacted?
ZipSlip issue when use fileutil package to unzip files.
Patches
Has the problem been patched? What versions should users upgrade to?
It will fixed in v2.1.10, Please upgrade version to v2.1.10 or above. Users who use v1.x.x should upgrade v1.3.4 or above.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
No, users have to upgrade version.
CWEs
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
References
- https://github.com/duke-git/lancet/security/advisories/GHSA-pp3f-xrw5-q5j4 ↗
- https://nvd.nist.gov/vuln/detail/CVE-2022-41920 ↗
- https://github.com/duke-git/lancet/issues/62 ↗
- https://github.com/duke-git/lancet/commit/f133b32faa05eb93e66175d01827afa4b7094572 ↗
- https://github.com/duke-git/lancet/commit/f869a0a67098e92d24ddd913e188b32404fa72c9 ↗
- https://pkg.go.dev/vuln/GO-2022-1114 ↗
- https://github.com/advisories/GHSA-pp3f-xrw5-q5j4 ↗