dwyl/hapi-auth-jwt2 · Security
Authentication Bypass in hapi-auth-jwt2
- GHSA ID
- GHSA-mg8r-9g6j-hwv9
- CVE ID
- CVE-2016-10525
- Severity
- critical
- Published
- Updated
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS v3
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Versions of hapi-auth-jwt2 prior to version 5.1.2 are affected by a complete authentication bypass vulnerability when in the try authentication mode.
Recommendation
Update to version 5.1.2 or later.
CWEs
- CWE-287 · Improper Authentication