element-hq/synapse · Security

Synapse V2 state resolution weakness allows Denial of Service (DoS)

GHSA ID
GHSA-3h7q-rfh9-xm4v
CVE ID
CVE-2024-31208
Severity
medium
Published
Updated
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS v3
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

Impact

A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service.

Servers in private federations, or those that do not federate, are not affected.

Patches

Server administrators should upgrade to 1.105.1 or later.

Workarounds

One can:

  • ban the malicious users or ACL block servers from the rooms; and/or
  • leave the room and purge the room using the admin API

For more information

If you have any questions or comments about this advisory, please email us at security AT element.io.

CWEs

References