expressjs/multer · Security

Multer Vulnerable to Denial of Service via Uncontrolled Recursion

GHSA ID
GHSA-5528-5vmv-3xc2
CVE ID
CVE-2026-3520
Severity
high
Published
Updated
CVSS v4
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

Impact

A vulnerability in Multer versions < 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow.

Patches

Users should upgrade to 2.1.1

Workarounds

None

Resources

CWEs

References