floriangaerber/magnesium-php · Security
Magnesium-PHP Injection vulnerability
- GHSA ID
- GHSA-8pp6-5qpw-85g3
- CVE ID
- CVE-2017-20187
- Severity
- low
- Published
- Updated
- CVSS
- 3.5 · CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CVSS v3
- 3.5 · CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Description
** UNSUPPORTED WHEN ASSIGNED ** ** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
CWEs
- CWE-74 · Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-20187 ↗
- https://github.com/floriangaerber/Magnesium-PHP/commit/500d340e1f6421007413cc08a8383475221c2604 ↗
- https://github.com/floriangaerber/Magnesium-PHP/releases/tag/v0.3.1 ↗
- https://vuldb.com/?ctiid.244482 ↗
- https://vuldb.com/?id.244482 ↗
- https://github.com/advisories/GHSA-8pp6-5qpw-85g3 ↗