getsentry/sentry · Security

Sentry vulnerable to incorrect credential validation on OAuth token requests

GHSA ID
GHSA-hgj4-h2x3-rfx4
CVE ID
CVE-2023-39531
Severity
medium
Published
Updated
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N
CVSS v3
6.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N

Description

Impact

An attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account.

Remediation

  • Sentry SaaS customers do not need to take any action. Those with the highest risk will be contacted directly by Sentry.
  • Self-hosted installations should upgrade to version 23.7.2 or higher.

Workarounds

There are no direct workarounds, but users should review applications authorized on their account (User Settings > Authorized Applications) and remove any that are no longer needed.

CWEs

References