github/gh-ost · Security
Command injection in gh-ost
- GHSA ID
- GHSA-rrp4-2xx3-mv29
- CVE ID
- CVE-2022-21687
- Severity
- medium
- Published
- Updated
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- CVSS v3
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
Description
Gh-ost version <= 1.1.2 allows users to inject DSN strings via the -database parameter.
This is a low severity vulnerability as the attacker must have access to the target host or trick an administrator into executing a malicious gh-ost command on a host running gh-ost, plus network access from host running gh-ost to the attack's malicious MySQL server.
Impact
This issue may lead to arbitrary local file read.
Patches
Fixed in 1.1.3+.
Workarounds
None
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in github/gh-ost
CWEs
- CWE-20 · Improper Input Validation
- CWE-74 · Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')