googlechrome/puppeteer · Security

Use-After-Free in puppeteer

GHSA ID
GHSA-c2gp-86p4-5935
CVE ID
CVE-2019-5786
Severity
medium
Published
Updated
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS v3
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Description

Versions of puppeteer prior to 1.13.0 are vulnerable to the Use-After-Free vulnerability in Chromium (CVE-2019-5786). The Chromium FileReader API is vulnerable to Use-After-Free which may lead to Remote Code Execution.

Recommendation

Upgrade to version 1.13.0 or later.

CWEs

References