googlechromelabs/critters · Security

Critters Cross-site Scripting Vulnerability

GHSA ID
GHSA-cx3j-qqxj-9597
CVE ID
CVE-2023-3481
Severity
medium
Published
Updated
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS v3
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Impact

Critters version 0.0.17-0.0.19 have an issue when parsing the HTML which leads to a potential cross-site scripting (XSS) bug.

Patches

The bug has been fixed in v0.0.20.

Workarounds

Upgrading Critters version to >0.0.20 is the easiest fix. This is a non breaking version upgrade so we recommend all users to use v0.0.20.

CWEs

References